Downtime on the Sentia server
Incident Report for IFS Ultimo
Resolved
All issues should be solved.
Posted Oct 21, 2023 - 14:24 CEST
Investigating
Currently we are experiencing some issues with our Sentia server.
Posted Oct 21, 2023 - 11:19 CEST