The email delivery issues with SendGrid appear to have been resolved. Over the past 30 minutes, all emails sent from the Ultimo application have been delivered successfully.
We will continue to monitor the situation closely. Should any further issues occur, we will provide an update via this Statuspage.
Posted Sep 04, 2026 - 15:11 CEST
Identified
We have identified the cause of the email delivery delays.
Our email service provider, Twilio SendGrid, is currently experiencing an incident that is affecting email delivery to Microsoft-hosted mail services, including Microsoft 365, Exchange Online, Outlook.com, and Hotmail.
As a result, some system-generated emails, notifications, and workflow messages from Ultimo environments may be delayed. Email delivery to other mail providers is operating normally.
Twilio SendGrid has acknowledged the issue and is actively working on a resolution. Deferred emails are automatically retried by the provider and are expected to be delivered once service is restored.
We continue to monitor the situation and will provide further updates as information becomes available.
Posted Sep 04, 2026 - 14:13 CEST
Investigating
We are currently experiencing issues with our external email service provider, which may impact the delivery of emails sent from Ultimo environments.
Users may experience delays in receiving system-generated emails, notifications, and workflow-related messages. We are actively investigating the issue together with our provider and will provide updates as more information becomes available.
Posted Sep 04, 2026 - 13:53 CEST
This incident affected: Customer portal and Non-Core Features and Services (Non-Core Features and Services - Australia, Non-Core Features and Services - Europe, Non-Core Features and Services - Germany, Non-Core Features and Services - India, Non-Core Features and Services - Sweden, Non-Core Features and Services - UK, Non-Core Features and Services - USA).