Bad performance Ultimo
Incident Report for IFS Ultimo
Resolved
Microsoft fixed the issue. All cases are resolved.
Posted Jun 16, 2023 - 11:04 CEST
Update
Current Status: Microsoft identified a recent network change caused the impact; they are in progress of applying mitigation. Internal telemetry shows good recovery in progress and many customers would start seeing improvement in connectivity, we estimate full recovery by approximately 08:00 UTC. The next update will be provided in 60 minutes, or as events warrant.
Posted Jun 16, 2023 - 08:35 CEST
Identified
Impact Statement: Microsoft identified a networking issue in West Europe region. Networking traffic to and from West Europe would have been affected and resources hosted in this region may experience reachability failures or latencies.

Current Status: We are aware of this issue and are in progress of applying mitigation. The next update will be provided in 60 minutes, or as events warrant.
Posted Jun 16, 2023 - 08:05 CEST
Investigating
We are experiencing longer than usual load times on our environments.
Posted Jun 16, 2023 - 08:04 CEST
This incident affected: Ultimo Cloud, BI Platform, and CAD / Reporting services.