We have concluded our investigation into the intermittent availability issues reported by a subset of customers.
Throughout our investigation, we did not identify any issues within the Ultimo platform, infrastructure, or application logs. Monitoring data showed normal operation of the Ultimo services during the reported timeframe.
The reported disruptions were limited to a subset of customers hosted in the West Europe region. Our investigation indicates that the observed connectivity issues were related to external network components outside of Ultimo's control and operational responsibility.
As Ultimo services have remained stable and no platform-related issues have been identified, this incident is now considered resolved.
We apologize for any inconvenience experienced and appreciate your patience while we investigated the reports.
Posted Sep 10, 2026 - 16:23 CEST
Identified
We continue to investigate intermittent availability issues affecting a subset of customer environments hosted in our West Europe infrastructure.
In addition to reports regarding Ultimo availability, we are aware that some affected customers have indicated experiencing intermittent connectivity issues with other Microsoft services. At this time, no corresponding incident has been published by Microsoft.
Our teams are actively investigating the issue and monitoring both our platform and the underlying infrastructure providers.
We will provide further updates as soon as more information becomes available.
Posted Sep 10, 2026 - 14:55 CEST
Update
We have completed and continue extensive investigation of the reported connectivity issues. At this time, we have not identified any errors, performance degradation, or service interruptions within the Ultimo platform itself. Our monitoring systems and application logs continue to show normal operation.
The reports received so far appear to be limited to some customers hosted in our West Europe region. We have not observed similar reports from customers in other regions. Due to the intermittent nature of the issue and the absence of corresponding errors in our environment, we are continuing to investigate potential external factors that may be contributing to the reported disruptions.
We are actively monitoring the situation and working with relevant infrastructure providers to gather additional information.
We will provide a further update as soon as more information becomes available.
We appreciate your patience and apologize for any inconvenience caused.
Posted Sep 10, 2026 - 13:56 CEST
Investigating
We are investigating reports of intermittent availability issues affecting a small subset of customer environments hosted in our West Europe infrastructure.
Customers may experience: - Difficulty accessing Ultimo - Slow response times - Intermittent errors during use - Barcode scanners not connecting, giving black screens
Our teams are actively investigating the issue and working to determine the root cause. We will provide further updates as soon as more information becomes available.
Posted Sep 10, 2026 - 12:27 CEST
This incident affected: Ultimo Cloud (Ultimo Cloud - Europe).