We’re pleased to report that access to the Ultimo Global Unified Support portal (portal.ultimo.net) has been fully restored.
Our team has completed all necessary testing, and the implemented solution has passed quality assurance. You can now log in and use the portal as normal.
Thank you for your patience and understanding while we resolved this issue. Should you experience any unexpected issues, please don’t hesitate to contact us at support@ultimo.com.
Posted Jul 25, 2025 - 08:42 CEST
Update
Ultimo Global Unified Support is currently unavailable through the customer side of the portal (portal.ultimo.net). We’re actively working to resolve the issue and are in the final stages of internal testing to ensure that the solution meets the highest quality standards. We expect to restore full portal access before the weekend, pending successful testing.
In the meantime, please reach out to us at support@ultimo.com for any support needs.
We’ll share another update within the next 48 hours. Ensuring uninterrupted support remains our top priority.
Thank you for your continued patience and trust.
Posted Jul 23, 2025 - 18:25 CEST
Update
We have identified the issues and are continuing to work of a fix for this. However implementing the solution and testing thoroughly takes time.
We will update more at a later stage.
Posted Jul 21, 2025 - 17:57 CEST
Identified
We're currently experiencing unfortunate issues with the customer side of the portal.
This means it is temporarily impossible to log into the customer portal and submit service requests or do any other actions. We're working hard to resolve this.
If you have any urgent issues, please call or email support@ultimo.com. If you have any further questions, please don't hesitate to contact us.