System Status: Not available
Incident Report for Ultimo Software Solutions
Resolved
This incident has been resolved.
Posted Jan 13, 2020 - 10:40 CET
Monitoring
Currently we are experiencing problems on our infrastructure, it is possible that you will experience degraded performance.

All further updates will be posted here on our status page.
Posted Jan 13, 2020 - 10:39 CET