Resolved
Incident Report for Ultimo Software Solutions
Resolved
Experienced unexpected downtime due to a problem at our hosting provider, after investigation it was caused by a faulty memory bank in a router.
Posted Oct 14, 2019 - 11:00 CEST